牛牛逼逼叉叉
菜单

使用if IE语句判断浏览器IE版本及添加升级提示

2014年06月21日,分类《前端开发》,作者:
博客捐助

实现方法

判断当前浏览器是否IE6(或IE6内核)

<!––[if IE 6]>
你使用的是IE6浏览器,这是IE的过期版本,是时候升级了!
<![endif]––>

判断当前浏览器是否IE7及以下版本

<!--[if lte IE 7]>
这段文字只会在IE7及(IE7/IE6/IE5等)以下版本显示
<![endif]-->

完整的判断IE及IE版本代码

判断是否IE

<!––[if IE]>
你正在使用的是IE浏览器
<![endif]––>

判断IE版本

<!––[if IE 6]>
你正在使用的IE版本是IE6
<![endif]––>
<!––[if IE 7]>
你正在使用的IE版本是IE7
<![endif]––>
<!––[if IE 8]>
你正在使用的IE版本是IE8
<![endif]––>
<!––[if IE 9]>
你正在使用的IE版本是IE9
<![endif]––>

以此类推

IE8以下版本提示浏览器升级

以下是“多梦主题”本站使用的主题使用的一段在IE7及以下版本提示浏览器升级的代码。

<!--[if lte IE 7]><script>window.location.href='http://istyle.qiniudn.com/upgrade-your-browser.html';</script><![endif]-->

把这段代码添加在网站头部代码</head>之前,当IE8以下版本浏览器(包括使用IE8以下版本内核的浏览器)访问网站的时候将自动跳转到浏览器升级提示页面。

自动调用IE最高版本

有的双核浏览器其中一核使用的就是IE内核,但是默认并不会调用最高版本,往往是模拟IE7,这个时候我们需要在网页头部添加一行代码让浏览器自动调用最高版本的IE来更好的支持HTML5和CSS3。

<meta http-equiv="X-UA-Compatible" content="IE=Edge" >

相关资料:设置X-UA-Compatible让网站调用IE最高版本或chrome内核



发表评论

电子邮件地址不会被公开。 必填项已用*标注

【上一篇】

多梦主题所有可以用的LOGO代码列表

【下一篇】

多梦主题可使用的GlyphiconHalflings字体图标