牛牛逼逼叉叉
菜单

wampserver2.5版本怎么让局域网其他人可以访问

2014年08月23日,分类《工具》,作者:
博客捐助

今天要说的是wamp最新的版本安装后怎么让别人可以访问。需要修改两处配置,往下看。

wampserver2.5最新版本

Apache : 2.4.9

MySQL : 5.6.17

PHP : 5.5.12

PHPMyAdmin : 4.1.14

SqlBuddy : 1.3.3

XDebug : 2.2.5

当你安装好之后打开httpd.conf看到的原始配置是下面这样的。原本的这种配置智能本机访问,其他人不能访问。

看见默认的配置你会发现出现了两个相同的。我感觉是相同的。而且2.5最新版本的httpd.conf文件默认用记事本打开是没有换行的。坑爹

但是你如果使用notepad++ 或者 sublime2或3打开就可以看见换行了

#
# DocumentR.........
#此处省略N行注释
#..............and aliases may be used to point to other locations.
#
DocumentRoot "D:/wamp/www/"
#
# Each directory.........
#此处省略N行注释
#..............its subdirectories). 
#
# First, we configure the "default" to be a very restrictive set of 
# features.  
#
<Directory />
    Require all denied
</Directory>
#
# Note that fro.........
#此处省略N行注释
#..............expect, make sure that you have specifically enabled it
# below.
#
<Directory "D:/wamp/www/">
    #
    # Possible values for the Options directive are "None", "All",
    #此处省略N行注释
    # for more information.
    #
    Options Indexes FollowSymLinks
    #
    # AllowOverride.........
    #此处省略N行注释
    #..............ileInfo AuthConfig Limit
    #
    AllowOverride all
    #
    # Controls who can get stuff from this server.
    #
#   onlineoffline tag - don't remove
    Require local
</Directory>

上面也说了上面的配置不行。下面就说说怎么改。上面我已经粘出来了2处地方,那我们要修改也就是这两处。

看下面的配置方法。

DocumentRoot "D:/wamp/www/"
<Directory />
    AllowOverride none
    order deny,allow
    allow from all
#    Require all denied
</Directory>

<Directory "D:/wamp/www/">
    Options Indexes FollowSymLinks
    AllowOverride all
    order deny,allow
    allow from all
#    Require local
</Directory>

上面的代码看完之后是不是明白了。两处地方都要修改其他人才能访问,只修改一处地方那别人访问的时候就会出现403的现象。

上面的代码就是我们把Require local注释掉,在添加AllowOverride all、order deny,allow、allow from all这三行,其他人就可以访问了。

但是总觉有两端相识的有点多余。你可以这样。只保留上面的也行。

DocumentRoot "D:/wamp/www/"
<Directory />
    AllowOverride none
    order deny,allow
    allow from all
#    Require all denied
</Directory>
下面的删除掉。
<Directory "D:/wamp/www/">
    Options Indexes FollowSymLinks
    AllowOverride all
    order deny,allow
    allow from all
#    Require local
</Directory>

我就是这样解决这个问题的。网上也找不到解决方法,可能是太专业了。我看不懂吧



wampserver2.5版本怎么让局域网其他人可以访问 有 11 条回应

  1. 2016年04月26日 在 16:42 匿名用户

    骗子,没用

    回复
    • 2016年04月26日 在 16:45 喵Mews

      如果没有用,你可以右键wamp选择上线就可以了

      回复
  2. 2016年04月26日 在 16:40 匿名用户

    额…打了赏,还评了论…怎么一刷新就没有了……..

    回复
    • 2016年04月26日 在 16:43 喵Mews

      什么没有了?

      回复
    • 2016年04月26日 在 16:46 喵Mews

      评论没有了因为进入了待审核,这下好了

      回复
  3. 2016年04月26日 在 16:40 匿名用户

    好,有用!之前两周还用的好好的,结果今天就不行….还重装了一次,看了楼主的文章解决了,原来是升级啦!!!之前用的2.4,也配好了的,没想到原来是因为升级了的原因!

    回复
  4. 2016年04月26日 在 16:37 匿名用户

    感谢楼主啊,找了多少天,终于解决了

    回复
  5. 2014年08月24日 在 18:12 松果

    沙发

    回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注

【上一篇】

收到微信5.4测试邀请(5.4可搜索到公众文章)

【下一篇】

收集的Android user-agent 分享一下